Have you needed to consolidate and migrate a filesystem that is spread over 2 physical disks onto 1 physical disk? You can easily do this in AIX without even unmounting the FS.
mjd@techmute mjd $ lspv
hdisk0 00007690a14d9fee rootvg
hdisk4 00007690a14cae39 None
hdisk5 0000769091324b51 rootvg
There is a FS on testlv that resides in rootvg but has active storage on both hdisk0 and hdisk5. To consolidate and move that filesystem to hdisk4, its as simple as 3 commands:
extendvg rootvg hdisk4
migratepv -l testlv hdisk5 hdisk4
At this point, half of the testlv is on hdisk4, and half is on hdisk0:
mjd@techmute mjd $ lspv -l hdisk4
hdisk4:
LV NAME LPs PPs DISTRIBUTION MOUNT POINT
testlv 100 100 00..67..33..00..00 /test
mjd@techmute mjd $ lspv -l hdisk0
hdisk0:
LV NAME LPs PPs DISTRIBUTION MOUNT POINT
[...]
testlv 100 100 39..61..00..00..00 /test
[...]
To finish the consolidation/move, migrate the last half.
mjd@techmute mjd $ migratepv -l testlv hdisk0 hdisk4
mjd@techmute mjd $ lspv -l hdisk4
hdisk4:
LV NAME LPs PPs DISTRIBUTION MOUNT POINT
testlv 200 200 66..67..67..00..00 /test
This is easier than trying to use cplv or restoring a backup onto the new disk.
No comments:
Post a Comment